Shop Forum More Submit  Join Login
I am out of ideas, so I am making the prototype tmg_gui package available for download.



There user will need to modify the code to configure the script for his computer environment, i.e., he will have to enter the locations of mesh files, anm files, and applications into the code.  Hopefully, the enclosed readme file will explain what you need to do to make the script work on your computer with your setup.



Add a Comment:
 
:iconmikedboing:
MikeDBoing Featured By Owner Jun 28, 2018  Professional Filmographer
So far it works beautifully. Just a minor hiccup: if i change the default folder to load meshes from and then change my mind and want to load another mesh, the program will return to its default settings and crash blender. Nothing major and i'm sure I probably screwed up somewhere in the code.
Reply
:iconlefty2016:
lefty2016 Featured By Owner Jun 28, 2018
Can't figure out what you are doing based on the description.  Maybe if you could give me a detailed walkthrough...?
Reply
:iconmikedboing:
MikeDBoing Featured By Owner Jul 5, 2018  Professional Filmographer
I changed the default folder from the blender folder to a folder called -=extracted=-, the -= are there to keep this folder at the top of the list no matter what other folders get added. So I import a mesh, in this case a set from the game. so far so good. Now at this point it may not be the mesh i wanted or there is another version somewhere that would be better so i hit file/new, it asks to erase all, i hit yes. The default blender folder is back as the current directory. So i reset it back to -=extracted=-. I import another mesh, this time it was an accessory. (glasses). Soon as i hit import, blender crashed. Hope this helps.

I tried to change the default directory once in the code but it didn't work so i reset it to the default code, using the ui instead to change the directory.
Reply
:iconlefty2016:
lefty2016 Featured By Owner Jul 5, 2018
Okay, I recognize the problem.  It happens to me if I reload the default blend.   I don't think it is related to changing the default startup directory.

I don't have a solution yet;  I have been working around the problem for now by killing Blender and restarting.  Apparently reloading the default doesn't reinitialize everything.  It's still early days, I am optimistic a solution will emerge.

This is useful input.  Thanks for sharing.
Reply
:iconanonim92:
Anonim92 Featured By Owner Jun 25, 2018
That's awesome! For convenience, you have to pack all these things into an exe file 😁
Reply
:iconmoviesbandit:
MoviesBandit Featured By Owner Jun 20, 2018
Thank you very much.
Reply
Add a Comment:
 
×

:iconlefty2016: More from lefty2016


More from DeviantArt



Details

Submitted on
June 20
Link
Thumb

Stats

Views
205
Favourites
1 (who?)
Comments
6
×