Closed to new replies
June 24, 2009


Replies: 24

Wacom Bamboo tablet issue - holding down pen becomes right click

ThisIsMetal Featured By Owner Jun 24, 2009
My Bamboo tablet has been terribly naughty lately.

When I press the pen to the tablet and don't move the pen, or only move it a small amount, red dots circle around the cursor. If I keep holding it down and don't move the pen enough, then it will display a little right click symbol for like three seconds, and if I release then it acts like I right clicked. If I keep holding it down after, the dots work normally and it acts as expected. Which basically means that any time I want to hold a button (say, a scrollbar button) down, or drag something, or DRAW A LINE, I have to either deal with horrible initial jerkiness or wait like five minutes for it to work properly - PER CLICK. For terribly obvious reasons, this is not optimal.

Yes, I've installed the most recent driver, and I've tried rummaging through the settings. No, I can't remember when it first started doing this. I'm running Windows XP - a friend of mine with Vista claims that he found an "enable press and hold for right-clicking" toggle box, but I had no such luck.

I'd be very appreciative if anybody was able to help me here!

Devious Comments

deshrubber Featured By Owner Mar 18, 2010  Hobbyist General Artist
Necro thread. :)

Alexander750 Featured By Owner Feb 9, 2010  Student General Artist
I read through wacom's driver bulletin and I think they address this issue. If I remember correctly a driver update caused this even when the right click mode was turned off. Newest driver is supposed to fix this heres a [link] Bulletin 091 to the driver bulletin. Thankfully it's pretty concise, so it's not a huge read.
Pufferfizh Featured By Owner Sep 5, 2009
It works! Thanks for the tip. Have been thinking of how to disable the function.
pyrohmstr Featured By Owner Sep 5, 2009  Professional Artist
it's supposed to do that fyi

its not the stylus...just change the settings in windows tablet and pen settings
AxleRose Featured By Owner Sep 3, 2009
This "Press and hold to right click" was seriously giving me the irrates as well.

To disable it in Vista:

1. Start Menu > All Programs > Tablet PC > Tablet PC Pen training.
2. In the Contents menu on the left click "For more information".
3. Customizing pen settings > Pen and Input Devices.
4. Under "Pen Actions" select "Press and Hold" then click on "Settings".
5. Untick "Enable press and hold for right clicking".

DONE! No more stupid annoying Vista loading circles when holding down your pen!
Chessbo Featured By Owner Feb 6, 2010
Super thanks for this!! works on windows 7!!!
kh013 Featured By Owner Oct 5, 2009
THANK YOU SO MUCH! :heart: This was driving me INSANE...
abtxb4x67 Featured By Owner Aug 7, 2009   Interface Designer
well is there any brand beside wacom...
i've just planned to buy a graphic tablet, but it seems that it is expensive enough..
random-jimmy Featured By Owner Aug 9, 2009
There are other brands, but of course not as good.

Look on ebay for the "slim" tablets - they are a decent size and yet pretty cheap

Otherwise, buy the small 'bamboo' from wacom - i got mine for $105 AUD and it works like a charm.
ThisIsMetal Featured By Owner Jul 26, 2009
For XP - the best fix I have is to uninstall and reinstall the driver, which so far has worked for me very well.

For Vista, there's apparently a checkbox in the Tablet Properties or something?

Maybe we SHOULD contact Wacom and get a definite answer once and for all, since this seems to be a common problem!
fat64 Featured By Owner Jul 26, 2009  Hobbyist Traditional Artist
I have Windows XP sp3 and it shows up here too. VERY annoying.


Maybe at : [link];p=5586

Maybe at : [link]
SonikaCreatives Featured By Owner Mar 12, 2010
Oh god. I love you! Marry me!!!
This saved my skin! It was driving me crazy (I have the Baboom tablet and the dreaded ring it's sort of light bluish). And to think it was with Windows Tablet PC Settings and not really Wacom >___<

Thank you!!!!
deshrubber Featured By Owner Mar 18, 2010  Hobbyist General Artist
Please do not comment in threads that are dormant for over two months. :)
fat64 Featured By Owner Mar 16, 2010  Hobbyist Traditional Artist
So should we marry this sunday? :O
berrier Featured By Owner Aug 6, 2009
i found this useful, thank you
fat64 Featured By Owner Aug 6, 2009  Hobbyist Traditional Artist
Oh , that makes me glad ^
Rukkukie Featured By Owner Jul 22, 2009  Student General Artist
I've got the same problem.. It's happened since I took the thing out the box >.<

It only does it on my laptop though :S
designgrrl Featured By Owner Jul 15, 2009
I have an intous 3 and this is happening to me. It is making me crazy. I don't know what made it happen. Whenever I tap and hold I get a ring of red dots plus a mouse icon with a red dot on the right button. I can't get rid of it. It does not happen on the wacom mouse just the pen and the pen is less than 4 months old. It started happening about 3 weeks ago. Not sure what changed. I have deleted my preferences and am about to uninstall and reinstall to see if it helps. #$%^&*!!
ThisIsMetal Featured By Owner Jul 15, 2009
If you have Vista, there should be an option to disable it in the properties somewhere.

I uninstalled the driver and reinstalled it, which seemed to work for me.
alekseyevich Featured By Owner Jun 25, 2009
Usually, to enable the press-and-hold thingie you'd have to hold down the right-click button of your stylus. Maybe your stylus is damaged and reports the button as pressed. You might want to try your frind's stylus.

The setting for this option should be in your Wacom-Tablet properties (or whatever that is in your language ;) ) when you choose "Functions" in the "Tools" row - that's where you set your ExpressKeys stuff and such. There is an "Options" button on the bottom of the side which affects the setting your friend mentioned.

ThisIsMetal Featured By Owner Jun 25, 2009
My stylus SHOULDN'T be damaged, as I just bought a new one fairly recently!

Also yeah I looked in the properties and the only tabs are "Pen" and "Tablet" - it is pretty useless.

ANYWAY. I completely uninstalled the driver, restarted, and reinstalled the driver - which seems to work! I was sort of loathe to try this because my computer really does not like booting up, so I generally just leave it on. (That's a problem for another day, though.) It is working happily now, though, and I'm getting a new computer in a month, so hopefully this won't be a problem for me any more.

Thank you for your help!
RoboCoonie Featured By Owner Jul 19, 2009  Professional Digital Artist
I'm having the same issue, but it didn't start until I upgraded the driver. I'm going to try downgrading to the driver that came on the CD and see if that fixes it. Otherwise, I'll be notifying Wacom of the issue. Perhaps they have a remedy.
alekseyevich Featured By Owner Jun 25, 2009
You're welcome, especially since it didn't do any help ;)

Just glad it works, wish you a ton of fun!
ThisIsMetal Featured By Owner Jun 26, 2009
Thank you!

I was actually able to use oC last night for drawing instead of just watching my friend draw. A ton of fun has been had!
Add a Comment: