99villages's avatar

Origami Weather 1.0

By 99villages
63 Favourites
44 Comments
14K Views
- An Origami-inspired weather skin For Rainmeter

- Best For minimal and clean desktops.

- Right-Click on any of the loaded weather skins and select " set location code" follow the instructions in the text file that opens to set up your weather location.

  Thanks for using this rainmeter weather skin.


Published:
Comments44
anonymous's avatar
Join the community to add your comment. Already a deviant? Log In
SuPerNoVi's avatar

Doesn't work. Installed followed instructions, just get question marks.

Clemzo33's avatar

Issue come back. I think The good way is describe by mindenhova .

I think now to used Weather.com services, it' necessary to get a licenseKey.

Clemzo33's avatar
Capture-2

It's really difficult to understand this random display.

Mauroarl's avatar

Same issue. Change to 1000 did not help

san09cio's avatar

just try it

GreenDragonSER's avatar

The same problem with displaying weather, showing black clouds.

mindenhova's avatar

I've got the same problem. One of my PCs can't show icons with the same error like @elliot4711. But on the other PC it works perfectly. I wieved the downloaded html tmp file... These are totally different... One of them is 470kib, the wrong is 1.7 Mib! The content is totally different too...


the good one starts like: "<!doctype html>

<html lang="hu-HU" itemScope itemType="http://schema.org/Organization" prefix="fb: http://ogp.me/ns/fb# og: http://ogp.me/ns# article: http://ogp" ...


the wrong is: "<!doctype html><html dir="ltr" lang="hu-HU"><head>

<script type='text/javascript' >window.NREUM||(NREUM={});NREUM.info = {"agent":"","beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"e6bbbab7f0" ...

elliot4711's avatar

Hey, recently this skin stopped showing any information (just question marks on dark clouds). I think this happened around 5/15 to 5/20 but I don't really remember when I first noticed it. Log gives three errors/warnings in this order:

RegExp matching error (-8) (Origami Weather\Weather Vertical\Weather Vertical Medium.ini - [@ForecastParent])

Not enough substrings (Origami Weather\weather Box\Weather Box Large.ini - [@CurrentLocationName])

RegExp matching error (-1) (Origami Weather\weather Box\Weather Box Large.ini - [@CurrentPressureChange])


Tried reinstalling and restarting but nothing changed, any idea what's going on?

99villages's avatar
99villagesStudent Interface Designer

Hey, I just checked and it works fine today. Do you still have the issue?

topherchrisb's avatar

I think the reason for the inconsistency ties to what mindenhova has indicated. Depending on your location you get a certain version of the site. Weather.com must be rolling out a new version slowly so depending on what edge node you get on their CDN determines what version of the site loads on your machine. I'm getting the broken version of the site with an IP of 25.66.140.134. If someone with a working version could post the IP they're loading we can hard code that as a temporary solution till new regex are generated/needed across the full CDN.

Clemzo33's avatar
Capture

Thank"s for your work but at this time that doesn't work

Clemzo33's avatar

Everything went back to normal a few moments ago;

I don't know why!

99villages's avatar
99villagesStudent Interface Designer

Hey, I believe its because the skin sends too many weather feed requests to weather.com and they temporarily ban it, a quick fix would be to change the update to 1000.

Right-click on the skin you are using and then select "edit skin" you will see the "update" at the beginning. change it from 100 to 1000 and save the file, then refresh the skin. I fill be rolling out an update to fix the issue Thanks.

elliot4711's avatar

Sadly still not working for me either, same errors as ClintPeacewood

ClintPeacewood's avatar
ClintPeacewoodHobbyist Digital Artist

Same issue. Change to 1000 did not help.

Here's my log file

Log Weather
voyagefx86's avatar
voyagefx86Hobbyist Traditional Artist

Changed the setting to reflect the "update" to 1000, clicked save and refreshed the skin and does not seem to work. Looks like a black cloud with a question mark still.

CalPlayman's avatar

Me as well. Something must have changed on the data site. Any news on an update? I love this skin and don't really want to switch to a different one.

Clemzo33's avatar

Same issue for me since this morning

tasvo65's avatar

Unfortuantly there is not Celsious unit option

DanPrice142's avatar

change language to en - GB it will change to celsious

jakiblue's avatar
jakiblueHobbyist Digital Artist
truly elegant skin, love it!
yeappa's avatar

gr8 work! is celcius available?

anonymous's avatar
Join the community to add your comment. Already a deviant? Log In